编译lede某个版本报错的问题

Collecting package info: done
Collecting target info: done
tmp/.config-package.in:15823:error: recursive dependency detected!
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:15823: symbol PACKAGE_lua is selected by PACKAGE_luci-base
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:31842: symbol PACKAGE_luci-base is selected by PACKAGE_luci-mod-admin-full
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:31948: symbol PACKAGE_luci-mod-admin-full is selected by PACKAGE_luci
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:31775: symbol PACKAGE_luci is selected by PACKAGE_ipset-lists
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:73600: symbol PACKAGE_ipset-lists is selected by PACKAGE_luci-app-shadowsocksr-pro
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:33153: symbol PACKAGE_luci-app-shadowsocksr-pro depends on PACKAGE_iptables
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:52311: symbol PACKAGE_iptables is selected by PACKAGE_sqm-scripts
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:895: symbol PACKAGE_sqm-scripts is selected by PACKAGE_luci-app-sqm
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection “Kconfig recursive dependency limitations”
tmp/.config-package.in:33249: symbol PACKAGE_luci-app-sqm depends on PACKAGE_lua
解决办法,删除/package/lean/ipset-lists/Makefile里面+luci
这个属于重复引用导致报错。

此条目发表在编译固件分类目录。将固定链接加入收藏夹。

发表评论

电子邮件地址不会被公开。 必填项已用*标注