标签归档:Cannot satisfy the following dependencies for luci-app-upnp: * libip6tc * ip6tables *

openwrt lede v17.01编译miniupnp时遇到的问题

禁用了ipv6,在编译miniupnp时遇到如下报错:

Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-upnp:
* libip6tc * ip6tables *
* opkg_install_cmd: Cannot install package luci-app-upnp.

实际上 luci-app-upnp并不依赖libip6tc 和 ip6tables ,而是miniupnpd依赖IPV6:libip6tc 和IPV6:ip6tables,解决办法就是禁用它们。

去feeds/routing/miniupnpd修改makefile文件,注释掉或者直接删除libip6tc和ip6tables即可。