标签归档:UBNT SDK编译

记录一下ubnt SDK的编译

首先需要安装32位linux环境,注意64位系统是不行的。原因也很简单,UBNT释放出SDK的时候,大概是在2011年左右,那个时候32位系统还是主流,64位系统非常少见。所以UBNT的SDK当时是在32位系统上运行的。根本没有考虑过兼容64位系统。

我使用的是ubuntu-14.04 32位版本。

如果使用更新的版本比如16.04会报错,原因不明。避开就好。

安装好后,需要安装下列包。

bash make gcc quilt bison flex autoconf libtool libncurses5-dev subversion wget g++ gawk zlib1g-dev cvs yui-compressor

然后解压缩SDK,运行make即可,如果有遗漏的包,系统会提示你的。

结果,还是不行,会报错。

quilt requires at least version 2.4 of GNU patch. You can download

无奈退回到ubuntu12.04

经过一番安装,终于进入系统。

问题来了,发现系统自带的源早已无法使用了。

我把源更新为阿里云的ubuntu14(参考网址https://www.jianshu.com/p/3fd50eaf9b6c)

deb http://mirrors.aliyun.com/ubuntu/ trusty main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://mirrors.aliyun.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://mirrors.aliyun.com/ubuntu/ trusty main restricted universe multiverse
deb-src http://mirrors.aliyun.com/ubuntu/ trusty-security main restricted universe multiverse
deb-src http://mirrors.aliyun.com/ubuntu/ trusty-updates main restricted universe multiverse
deb-src http://mirrors.aliyun.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb-src http://mirrors.aliyun.com/ubuntu/ trusty-backports main restricted universe multiverse

然后安装bash make gcc quilt bison flex autoconf libtool libncurses5-dev subversion wget g++ gawk zlib1g-dev cvs yui-compressor

然后make,目前暂时没发现问题。